Backwards compatibility with PHP 5.6

PHP has evolved a lot in the last couple of years, and has taken big leaps forward in both speed and functionality since the release of version 7. To allow us to keep pushing forward and take the most from this beautiful language and to be able to support the latest versions, we have decided to drop native support for PHP5.6, which has been officially ‘end of life’ since December 2018.

In our PDF plugin, starting from version 2.8.0, we will ship support for PHP 8.0. Due to backwards incompatible changes, this means that the minimum PHP version required to use our plugin will step up to 7.1 by default (which has been end-of-life since December 2019).

Stuck on PHP7.0 or older? We’ve got you covered! #

If for any reason you can’t update your PHP version, we deliver a small add-on that utilizes an old version of our PDF component (the most version critical part of the plugin) and still allow you to use our plugin with PHP 5.6 or 7.0. This is only meant as a temporary solution. Using outdated versions of PHP is a security risk and will ultimately leave you stuck on old versions of WordPress/WooCommerce and plugins too, adding to that risk. We strongly recommend to reach out to your host or site maintainer to upgrade PHP to 7.1 or higher (7.4 or 8.0+ recommended).

Add-on installation instructions: #

  1. Download the add-on here
  2. In your WordPress Administration panel go to: Plugins > Add new > Upload plugin
  3. Upload the add-on ZIP file and enable it

If you see any error or need help with any of the above, just send us an email: